// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[0-3]|[6-9])[0-9]*|[54]\d{4,}$").unwrap();
let string = "1500
26489
212
15849
5000
5001
4584
2402
5191981
4618916
6540
4500
45000
9999999
4001
4000
3999
5999
6000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}