re = /^(?:[0-3]|[6-9])[0-9]*|[54]\d{4,}$/m
str = '1500
26489
212
15849
5000
5001
4584
2402
5191981
4618916
6540
4500
45000
9999999
4001
4000
3999
5999
6000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end