re = /^(\+?\d+ ?)?(\(\d{1,}\) ?)?([\d\- ]+)*\d$/m
str = '+27824908354
+27 82 490 8354
+27(82)4908354
+27(82)490 8354
+27(82)490-8354
+27(82)490-- 8354
+27(82)490-8354
0824908354
(082)4908354'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end