# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\*{2}(.+?)\*{2}/<b>$1<\/b>/ig;t' <<< "**1** Blah **3** Blah **I am * all bold**"