$re = '/\*{2}(.+?)\*{2}/i';
$str = '**1** Blah **3** Blah **I am * all bold**';
$subst = "<b>$1</b>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;