package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\*{2}(.+?)\*{2}`)
var str = `**1** Blah **3** Blah **I am * all bold**`
var substitution = "<b>$1</b>"
fmt.Println(re.ReplaceAllString(str, substitution))
}