import Foundation
let pattern = #"\*{2}(.+?)\*{2}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"**1** Blah **3** Blah **I am * all bold**"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<b>$1</b>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)