// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\*{2}(.+?)\*{2}").unwrap();
let string = "**1** Blah **3** Blah **I am * all bold**";
let substitution = "<b>$1</b>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}