#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)\*{2}(.+?)\*{2}"
Local $sString = "**1** Blah **3** Blah **I am * all bold**"
Local $sSubst = "<b>$1</b>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)