use strict;
my $str = '**1** Blah **3** Blah **I am * all bold**';
my $regex = qr/\*{2}(.+?)\*{2}/ip;
my $subst = '<b>$1</b>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";