using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*{2}(.+?)\*{2}";
string substitution = @"<b>$1</b>";
string input = @"**1** Blah **3** Blah **I am * all bold**";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}