# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\|*\d+\/\Q{someInformation}\E\|*//g;t' <<< "0/{someInformation}|2/{moreInformation}|3/{someInformation}"