using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|*\d+/\Q{someInformation}\E\|*";
string substitution = @"";
string input = @"0/{someInformation}|2/{moreInformation}|3/{someInformation}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}