#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\|*\d+/\Q{someInformation}\E\|*"
Local $sString = "0/{someInformation}|2/{moreInformation}|3/{someInformation}"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)