const regex = new RegExp('\\|*\\d+/\\Q{someInformation}\\E\\|*', 'g')
const str = `0/{someInformation}|2/{moreInformation}|3/{someInformation}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);