import Foundation
let pattern = #"\|*\d+/\Q{someInformation}\E\|*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"0/{someInformation}|2/{moreInformation}|3/{someInformation}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)