// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\|*\d+/\Q{someInformation}\E\|*").unwrap();
let string = "0/{someInformation}|2/{moreInformation}|3/{someInformation}";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}