$re = '~\|*\d+/\Q{someInformation}\E\|*~';
$str = '0/{someInformation}|2/{moreInformation}|3/{someInformation}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;