use strict;
my $str = '0/{someInformation}|2/{moreInformation}|3/{someInformation}';
my $regex = qr~\|*\d+/\Q{someInformation}\E\|*~p;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";