# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/#([\w.]+)/<a href="\/tag\/$1">#$1<\/a>/gmu;t' <<< "#quote#öquoteoftheday #şmyquote"