#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)#([\w.]+)"
Local $sString = "#quote#öquoteoftheday #şmyquote"
Local $sSubst = "<a href="/tag/$1">#$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)