// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)#([\w.]+)").unwrap();
let string = "#quote#öquoteoftheday #şmyquote";
let substitution = "<a href=\"/tag/$1\">#$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}