using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#([\w.]+)";
string substitution = @"<a href=""/tag/$1"">#$1</a>";
string input = @"#quote#öquoteoftheday #şmyquote";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}