use strict;
my $str = '#quote#öquoteoftheday #şmyquote';
my $regex = qr/#([\w.]+)/mup;
my $subst = '<a href="/tag/$1">#$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";