import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(( *\\n+|\\A) *)";
final String string = " <div class=\"input select\">\n"
+ " <label for=\"countries\">User Country</label>\n"
+ " <select name=\"countries\" id=\"countries\">\n"
+ " <option value=\"\">Select a country</option>\n"
+ " <option value=\"ger\">Germany</option>\n"
+ " <option value=\"fra\">France</option>\n"
+ " <option value=\"rus\" selected=\"selected\">Russia</option>\n"
+ " </select>\n"
+ " </div>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}