#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)((?<dq>\"[^"]*)\s*\")|((?<sq>\'[^']*)\s*\')|((?<bt>\`[^`]*)\s*\`)| "
Local $sString = "function myFunction() {" & @CRLF & _
" let carName = "Volvo";" & @CRLF & _
" // code here CAN use carName" & @CRLF & _
"const test = 'string with "quoted substring"';" & @CRLF & _
"("and another string th'' as' asd 'ere")" & @CRLF & _
"labelForStrings: {" & @CRLF & _
" `t'is a "string"`" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"/*asd *****" & @CRLF & _
"* 324 @*l;;?\\\" & @CRLF & _
"* multiline comment " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"*** /" & @CRLF & _
"*/"
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)