re = /((?<dq>\"[^"]*)\s*\")|((?<sq>\'[^']*)\s*\')|((?<bt>\`[^`]*)\s*\`)| /i
str = 'function myFunction() {
let carName = "Volvo";
// code here CAN use carName
const test = \'string with "quoted substring"\';
("and another string th\'\' as\' asd \'ere")
labelForStrings: {
`t\'is a "string"`
}
}
/*asd *****
* 324 @*l;;?\\\\\\
* multiline comment
*** /
*/'
subst = '$1$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result