using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<dq>\""[^""]*)\s*\"")|((?<sq>\'[^']*)\s*\')|((?<bt>\`[^`]*)\s*\`)| ";
string substitution = @"$1$2$3";
string input = @"function myFunction() {
let carName = ""Volvo"";
// code here CAN use carName
const test = 'string with ""quoted substring""';
(""and another string th'' as' asd 'ere"")
labelForStrings: {
`t'is a ""string""`
}
}
/*asd *****
* 324 @*l;;?\\\
* multiline comment
*** /
*/";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}