use strict;
my $str = 'function myFunction() {
let carName = "Volvo";
// code here CAN use carName
const test = \'string with "quoted substring"\';
("and another string th\'\' as\' asd \'ere")
labelForStrings: {
`t\'is a "string"`
}
}
/*asd *****
* 324 @*l;;?\\\\\\
* multiline comment
*** /
*/';
my $regex = qr/((?<dq>\"[^"]*)\s*\")|((?<sq>\'[^']*)\s*\')|((?<bt>\`[^`]*)\s*\`)| /ip;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";