package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((?<dq>\"[^"]*)\s*\")|((?<sq>\'[^']*)\s*\')|((?<bt>\`[^`]*)\s*\`)| `)
var str = `function myFunction() {
let carName = "Volvo";
// code here CAN use carName
const test = 'string with "quoted substring"';
("and another string th'' as' asd 'ere")
labelForStrings: {
\`t'is a "string"\`
}
}
/*asd *****
* 324 @*l;;?\\\
* multiline comment
*** /
*/`
var substitution = "$1$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}