import re
regex = re.compile(r"((?<dq>\"[^\"]*)\s*\")|((?<sq>\'[^']*)\s*\')|((?<bt>\`[^`]*)\s*\`)| ", flags=re.IGNORECASE)
test_str = ("function myFunction() {\n"
" let carName = \"Volvo\";\n"
" // code here CAN use carName\n"
"const test = 'string with \"quoted substring\"';\n"
"(\"and another string th'' as' asd 'ere\")\n"
"labelForStrings: {\n"
" `t'is a \"string\"`\n"
" }\n"
"}\n"
"/*asd *****\n"
"* 324 @*l;;?\\\\\\\n"
"* multiline comment \n\n\n"
"*** /\n"
"*/")
subst = "$1$2$3"
result = regex.sub(subst, test_str)
if result:
print(result)