const regex = /((?<dq>\"[^"]*)\s*\")|((?<sq>\'[^']*)\s*\')|((?<bt>\`[^`]*)\s*\`)| /gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<dq>\\"[^"]*)\\s*\\")|((?<sq>\\\'[^\']*)\\s*\\\')|((?<bt>\\`[^`]*)\\s*\\`)| ', 'gi')
const str = `function myFunction() {
let carName = "Volvo";
// code here CAN use carName
const test = 'string with "quoted substring"';
("and another string th'' as' asd 'ere")
labelForStrings: {
\`t'is a "string"\`
}
}
/*asd *****
* 324 @*l;;?\\\\\\
* multiline comment
*** /
*/`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);