using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[url(?:](https?://[^[]+)|(?:=""(https?://[^""]+)"")](.+?))\[/url]";
string input = @"[URL]www.no.http.example.com[/URL]
[url]https://any.com/any[/url]
[url=""nourl""]nourl[/url]
[URL=""https://any.com/any?any=333""]text text[/URL]
[url=""http://www.emptyTEXT.com""][/url]
[url]http://www.any.com/any?any=44#sss[/url]";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}