$re = '~\[url(?:](https?://[^[]+)|(?:="(https?://[^"]+)")](.+?))\[/url]~i';
$str = '[URL]www.no.http.example.com[/URL]
[url]https://any.com/any[/url]
[url="nourl"]nourl[/url]
[URL="https://any.com/any?any=333"]text text[/URL]
[url="http://www.emptyTEXT.com"][/url]
[url]http://www.any.com/any?any=44#sss[/url]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);