# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[url(?:](https?://[^[]+)|(?:=\"(https?://[^\"]+)\")](.+?))\[/url]"
test_str = ("[URL]www.no.http.example.com[/URL]\n"
"[url]https://any.com/any[/url]\n"
"[url=\"nourl\"]nourl[/url]\n"
"[URL=\"https://any.com/any?any=333\"]text text[/URL]\n"
"[url=\"http://www.emptyTEXT.com\"][/url]\n"
"[url]http://www.any.com/any?any=44#sss[/url]")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.