// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)\[url(?:](https?://[^[]+)|(?:="(https?://[^"]+)")](.+?))\[/url]"#).unwrap();
let string = "[URL]www.no.http.example.com[/URL]
[url]https://any.com/any[/url]
[url=\"nourl\"]nourl[/url]
[URL=\"https://any.com/any?any=333\"]text text[/URL]
[url=\"http://www.emptyTEXT.com\"][/url]
[url]http://www.any.com/any?any=44#sss[/url]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}