const regex = new RegExp('\\[url(?:](https?://[^[]+)|(?:="(https?://[^"]+)")](.+?))\\[/url]', 'gi')
const str = `[URL]www.no.http.example.com[/URL]
[url]https://any.com/any[/url]
[url="nourl"]nourl[/url]
[URL="https://any.com/any?any=333"]text text[/URL]
[url="http://www.emptyTEXT.com"][/url]
[url]http://www.any.com/any?any=44#sss[/url]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}