import Foundation
let pattern = #"\[url(?:](https?://[^[]+)|(?:="(https?://[^"]+)")](.+?))\[/url]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
[URL]www.no.http.example.com[/URL]
[url]https://any.com/any[/url]
[url="nourl"]nourl[/url]
[URL="https://any.com/any?any=333"]text text[/URL]
[url="http://www.emptyTEXT.com"][/url]
[url]http://www.any.com/any?any=44#sss[/url]
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)