package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[url(?:](https?://[^[]+)|(?:="(https?://[^"]+)")](.+?))\[/url]`)
var str = `[URL]www.no.http.example.com[/URL]
[url]https://any.com/any[/url]
[url="nourl"]nourl[/url]
[URL="https://any.com/any?any=333"]text text[/URL]
[url="http://www.emptyTEXT.com"][/url]
[url]http://www.any.com/any?any=44#sss[/url]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}