# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.+)(?=GitHub)|([^\/]+)$//g;t' <<< "/C/Users/mia261/GitHub/fake_folder/folder2/TO-DO.txt"