using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+)(?=GitHub)|([^/]+)$";
string substitution = @"";
string input = @"/C/Users/mia261/GitHub/fake_folder/folder2/TO-DO.txt";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}