use strict;
my $str = '/C/Users/mia261/GitHub/fake_folder/folder2/TO-DO.txt';
my $regex = qr/^(.+)(?=GitHub)|([^/]+)$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";