const regex = new RegExp('^(.+)(?=GitHub)|([^/]+)$', 'g')
const str = `/C/Users/mia261/GitHub/fake_folder/folder2/TO-DO.txt`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);