import re
regex = re.compile(r"^(.+)(?=GitHub)|([^/]+)$")
test_str = "/C/Users/mia261/GitHub/fake_folder/folder2/TO-DO.txt"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)