import Foundation
let pattern = #"^(.+)(?=GitHub)|([^/]+)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/C/Users/mia261/GitHub/fake_folder/folder2/TO-DO.txt"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)