re = /^(.+)(?=GitHub)|([^\/]+)$/
str = '/C/Users/mia261/GitHub/fake_folder/folder2/TO-DO.txt'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result