$re = '/^(.+)(?=GitHub)|([^/]+)$/';
$str = '/C/Users/mia261/GitHub/fake_folder/folder2/TO-DO.txt';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;