using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^a-zA-Z_\x7f-\xff\d]";
string input = @"Building Wire/MC
OSHA 30
EMT 1/2"" to 2""
EMT 2 1/2"" to 4""
Cooperation & Conduct";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}