// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^a-zA-Z_\x7f-\xff\d]").unwrap();
let string = "Building Wire/MC
OSHA 30
EMT 1/2\" to 2\"
EMT 2 1/2\" to 4\"
Cooperation & Conduct";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}