const regex = /[^a-zA-Z_\x7f-\xff\d]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z_\\x7f-\\xff\\d]', 'g')
const str = `Building Wire/MC
OSHA 30
EMT 1/2" to 2"
EMT 2 1/2" to 4"
Cooperation & Conduct`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}